Вопрос по информатике:
составьте программу, которая формирует массив, содержащий 16 случайных чисел, принадлежащих промежутку [-2;3], и подсчитывает сумму отрицательных чисел.вывод в строку через запятую
- 12.07.2018 04:27
- Информатика
- remove_red_eye 10920
- thumb_up 90
Ответы и объяснения 1
Program Program1;
var
i,sum:integer;
A: array [1..16] of integer;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=random(6)-2;
write(a[i],', ');
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln('Сумма отрицательных чисел равна',sum);
end.
- 13.07.2018 15:55
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.