Вопрос по информатике:
составьте программу , которая заполняет массив случайными целыми числами в диапозоне от 1 до 100 , затем меняет местами наименьший четный элемент с наибольшим нечетным элементом
- 15.09.2017 09:37
- Информатика
- remove_red_eye 5909
- thumb_up 77
Ответы и объяснения 1
Program Pr1;
uses crt;
var mas:array[1..10] of integer;
i,max,min,a,b:integer;
Begin
clrscr;
max:=0;
min:=150;
randomize;
for i:=1 to 10 do mas[i]:=1+random(100);
for i:=1 to 10 do write(mas[i]);
for i:=1 to 10 do begin if (mas[i] mod 2=0) and (mas[i]>max) then begin
max:=mas[i];
a:=i;
end;
if (mas[i] mod 2=0) and (mas[i]
b:=i;
end;
end;
i:=mas[a];
mas[a]:=mas[b];
mas[b]:=i;
writeln();
for i:=1 to 10 do write(mas[i]);
end.
- 16.09.2017 03:17
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.