Вопрос по информатике:
составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива
- 05.11.2015 12:46
- Информатика
- remove_red_eye 7780
- thumb_up 32
Ответы и объяснения 1
Var
a: array [1..10] of Word;
i:word;
sa:real;
begin
randomize;
for i:=1 to 10 do
begin
a[i]:=random(10)+1;
write(a[i]);
if i10 then write(', ');
end;
writeln;
sa:=0;
for i:=1 to 10 do
sa:=sa+a[i];
sa:=sa/10;
writeln('Sredneearifmitichiskoe: ',sa:0:3);
write('Dly vyhoda nagmite Enter');
readln;
end.
- 06.11.2015 13:41
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.