Вопрос по информатике:
Помогите пожалуйста Решить 2 задачи на языке Паскаль!
1)
По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.
Операцией возведения в степень пользоваться нельзя!
2)
В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.
Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.
- 04.05.2018 08:38
- Информатика
- remove_red_eye 713
- thumb_up 51
Ответы и объяснения 1
1)
Program Pr1;
uses crt;
var n,i:integer;
x:real;
Begin
clrscr;
readln(n);
for i:=1 to n do if exp(i*ln(2))
2)
Program Pr1;
uses crt;
var i,r,y:integer;
a,x:real;
begin
clrscr;
readln(x,y);
i:=1;
while x<=y do begin
x:=x+0.1*x;
i:=i+1;
end;
writeln(i);
end.
- 05.05.2018 04:25
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.