Вопрос по информатике:
помогите решить задачи 8 класс по информатике!решаются они через турбо Паскаль.
1)Найти колличество нечетных делителей натурального числа,больших К(К вводятся с клавиатуры).
2)Найдите все натуральные числа х,у,z из интервала от 1 до 20,для которых выполняется равенство : ху(квадрат)=z(квадрат)
СРОЧНО НАДОО ПОМОГИТЕ!
- 19.11.2015 22:31
- Информатика
- remove_red_eye 5970
- thumb_up 12
Ответы и объяснения 1
var s:integer;
i,k:longint;
begin
readln(k);
i:=3;
while i
if k div i=k/i then inc(s);
end;
writeln(s,' delitelei');
end.
var i,j:integer;
begin
for i:=1 to 20 do
for j:=1 to 20 do
if sqr(j)*i<20 then writeln('x=', i,' y=', j,' z=', sqr(j)*i);
end.
- 21.11.2015 07:57
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.