Вопрос по информатике:
Составьте программу, которая: а) из слова «ИНСТРУМЕНТЫ» составляет слова: «СТРУНЫ», «ТРУС», «ТУРИСТ»; б) из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово «ШРИФТ»; в) считает, сколько раз в тексте, заданном с клавиатуры, встречается буква «М».
- 23.11.2015 12:15
- Информатика
- remove_red_eye 14570
- thumb_up 48
Ответы и объяснения 2
var a:string;
begin
readln(a);
writeln(a[3],a[4],a[5],a[6],a[9],a[11]);
writeln(a[4],a[5],a[6],a[3]);
writeln(a[4],a[6],a[5],a[1],a[3],a[4]);
end.
var a,b,c:string;
begin
readln(a,b,c);
writeln(a[1],c[2],a[2],b[1],c[1]);
end.
var a:string; i:integer;
begin
readln(a);
while pos('М',a)0 do begin
inc(i);
delete(a,pos('М',a),1);
end;
writeln(i);
end.
- 23.11.2015 22:48
- thumb_up 44
странное задание, но все же:
#include
#include
#include
bool compose( std::vector &input, std::wstring result )
{
for( int i = 0; i < result.size(); ++i ) {
bool found( false );
for( int j = 0; j < input.size(); ++j ) {
if( input[j].find( result[i] ) != -1 ) {
found = true;
input[j].erase( input[j].begin() + input[j].find( result[i] ) );
}
}
if( found == false )
return false;
}
std::wcout << L"----\n;br /> for( int i =
- 25.11.2015 07:00
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.