Вопрос по информатике:
Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4)2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, вычитания и умножения; 2) каждое выражение может содержать только одну арифметическую операцию
- 27.09.2018 18:14
- Информатика
- remove_red_eye 12580
- thumb_up 258
Ответы и объяснения 1
var y,x:real;
begin
readln(x);
y:=2*(1-x*x+2.5*x*x*x+x*x*x*x);
writeln(x);
end.
var x,y,z:real;
begin
readln(x);
y:=-x*x;
z:=y*x;
z:=2.5*z;
y:=y+z;
z:=z*x;
y:=y+z;
y:=y+1;
y:=y*2;
writeln(y);
end.
- 28.09.2018 00:58
- thumb_up 70
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.