Вопрос по информатике:
составить программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами
- 24.01.2018 15:04
- Информатика
- remove_red_eye 14484
- thumb_up 78
Ответы и объяснения 1
var
a: array [1..10] of integer;
i, max: integer;
begin
max:= 0;
write('Исходный массив: ');
for i:= 1 to 10 do
begin
a[i]:= random(10);
write(a[i], ' ');
if (i mod 2 = 0) and (a[i] > max) then
max:= a[i];
end;
writeln;
writeln('Максимальный элемент массива среди элементов с четными индексами: ', max);
end.
Если что не понятно - спрашивай.
- 25.01.2018 07:34
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.