Вопрос по информатике:
составить программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент массива и его индекс
- 23.09.2017 07:49
- Информатика
- remove_red_eye 10996
- thumb_up 84
Ответы и объяснения 1
var
a: array [1..10] of integer;
i, min, MinIndex: integer; {min - значение минимального элемента массива, MinIndex - индекс минимального элемента массива}
begin
min:= 20;
write('Исходный массив: ');
for i:= 1 to 10 do
begin
a[i]:= random(19) + 1;
write(a[i], ' ');
if a[i] < min then
begin
min:= a[i];
MinIndex:= i;
end;
end;
writeln;
write('Минимальный элемент массива: a[', MinIndex, '] = ', min);
writeln;
end.
- 24.09.2017 17:07
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.