Вопрос по информатике:
составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел-на произведение этих чисел.помогите пожалуйста,очень надо!
- 04.02.2017 07:54
- Информатика
- remove_red_eye 14780
- thumb_up 64
Ответы и объяснения 2
var x,y,k:real;
begin
readln(x,y);
if x>y then begin k:=y; y:=(y+x)/2; x:=x*k end
else begin k:=x; x:=(x+y)/2; y:=y*k; end;
writeln(x,y,);
end.
- 04.02.2017 23:45
- thumb_up 41
var
a, b, c: real; {a и b - вводимые с клавиатуры числа, c - буферная переменная, которая будет содержать значение переменной a}
begin
writeln('Введите 2 числа');
readln(a, b); //Вводим числа
c:= a;
if a < b then {Если a < b, то заменяем а на среднее арифметическое этих чисел, b - на произведение этих чисел и распечатываем их}
begin
a:= (a + b) / 2;
b:= c * b;
writeln('a a = ', a, ', b = ', b);
end;
if b < a then {Если b < a, то заменяем а на произведение чисел, b - на среднее арифметическое чисел}
begin
a:= a * b;
b:= (c + b) / 2;
writeln('b a = ', a, ', b = ', b);
end;
if a = b then writeln('Числа равны'); {Числа числа равны, то печатаем сообщение об этом}
end.
Если все правильно, отметь решение как лучшее)
- 06.02.2017 11:58
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.