Вопрос по информатике:
Составьте программу вычисления количеств трёхзначных чисел, у которых сумма цифр является чётным числом.
- 12.05.2018 07:36
- Информатика
- remove_red_eye 11595
- thumb_up 75
Ответы и объяснения 1
var
i1, i2, i3: 1..9; //Цифры трехзначного числа
i, n: integer; //n - количество трехзначных чисел, у которых ...
begin
n:= 0; //Обнуляем счетчик
for i:= 100 to 999 do //Перебираем все трехзначные числа и считаем количество
begin
i1:= i div 100;
i2:= (i mod 100) div 10;
i3:= i mod 10;
if (i1 + i2 + i3) mod 2 = 0 then n:= n + 1;
end;
writeln('Количество трехзначных чисел, у которых сумма цифр является четным числом равна: ', n); //Выводим количество
end.
Если все правильно, отметь решение как лучшее)
- 13.05.2018 05:56
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.