Вопрос по информатике:
составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом R и началом в точке O(a,b) ХОТЯ БЫ ПРИМЕРНО
- 23.06.2018 23:09
- Информатика
- remove_red_eye 6570
- thumb_up 63
Ответы и объяснения 1
var
x, y, R, Oa, Ob: real;
begin
writeln('Введите радиус окружности R');
readln(R);
writeln('Введите координаты центра окружности');
readln(Oa, Ob);
writeln('Введите координаты точки');
readln(x, y);
if (x > (Oa - R)) and (x (Ob - R)) and (y < (Ob + R)) then
writeln('Точка с заданными координатами лежит внутри круга')
else
writeln('Точка с заданными координатами лежит вне круга');
end.
Если все правильно, отметь решение как лучшее)
- 25.06.2018 06:34
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.