Вопрос по информатике:
Составьте программу нахождения трёхзначного числа , куб суммы цифр которого равен ему самому
- 19.04.2018 11:50
- Информатика
- remove_red_eye 10656
- thumb_up 103
Ответы и объяснения 1
var
a,b,c,n:integer;
begin
for n:=100 to 999 do
begin
a:= n div 100;
b:= n div 10 mod 10;
c:= n mod 10;
if (a+b+c)*(a+b+c)*(a+b+c)=n then writeln(n);
end;
end.
и в результате получаем, что это число 512
- 20.04.2018 14:29
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.