Вопрос по информатике:
1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди элементов с нечётными индексами
2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве
- 15.11.2017 22:16
- Информатика
- remove_red_eye 11503
- thumb_up 22
Ответы и объяснения 1
Первое.
var
a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадкових чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]
end.
Второе
var
a:array[0..9] of integer;
i,y,s,max:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадкових чисел');
max:=a[0];
for i:=1 to 9 do
if a[i]
s:=0; // сума чисел, що приймають таке значення
for i:=0 to 9 do
if a[i]=max then s:=s+1;
writeln('Зустричается ',s,' раз.');
end.
- 17.11.2017 06:27
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.