Вопрос по информатике:
Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)
- 19.08.2018 16:10
- Информатика
- remove_red_eye 18901
- thumb_up 87
Ответы и объяснения 1
var x,y,a:integer;
c:boolean;
begin
readln(x); {считываем}
a:=1;
repeat
writeln(a,' попытка выбор компьютера пал на - ');
y:=random(x)+1; {задаем промежуток рандомом}
write(y);
if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}
until c; {если с=true тогда выход из цикла, иначе крутимся дальше}
writeln('Компьютер сделал ',a,' попыток.');
end.
Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.
- 19.08.2018 21:36
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.