Вопрос по информатике:
Срочно! Помогите! Написать программу в турбо паскале
Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить, есть ли в нем одинаковые соседние элементы.
Пример:
Исходный массив:
4 0 1 2 0 1 3 1 1 0
Заранее огромное спасибо!!!!
- 03.05.2018 01:47
- Информатика
- remove_red_eye 12479
- thumb_up 83
Ответы и объяснения 1
var
a: array [1..10] of integer; //Массив из 10 целочисленных элементов
i: integer;
begin
write('Исходный массив: ');
for i:= 1 to 10 do {Заполняем массив случайными числами от 0 до 4 и печатаем его}
begin
a[i]:= random(4);
write(a[i], ' ');
end;
writeln; //Перевод на новую строку
write('Одинаковые соседние элементы: ');
for i:= 1 to 9 do //Печатаем одинаковые соседние элементы
if a[i] = a[i + 1] then write('a[', i, '] = a[', i + 1, '], ');
writeln; {Перевод на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}
end.
- 04.05.2018 08:16
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.