Вопрос по информатике:
Напишите программу,которая содержит описание типов данных и подпрограмм для обработки одномерногго массива размерностью n , где n<=15.Программа должна состоять из подпрограмм:
a)Ввод элементов массива с клавиатуры
b)Функции возвращающей сумму четных элементов массива
c)Функции выводящей на экран минимальный элемент массива
- 12.02.2018 12:35
- Информатика
- remove_red_eye 19225
- thumb_up 59
Ответы и объяснения 1
Комментарии:
Вот описание своего типа данных:
type
pArray = array [1..15] of integer;
Вот проверка на правильно введенноее значение от 1 до 15:
while (N15) do, если введешь неправильно спросит еще раз
Подпрограммы:
Ввод элементов массива с клавиатуры здесь: procedure InputArray
Функции возвращающей сумму четных элементов массива: function SummOfEven
Функции выводящей на экран минимальный элемент массива: function MinimalElement
program ArrayProccessor;
uses crt;
type
pArray = array [1..15] of integer;
var myArray: pArray;
N:integer;
procedure InputArray(var arrayToInput:pArray; n:integer);
var i:integer;
begin
for i:=1 to n do
begin
write('vvedite a[',i,']=');
readln(arrayToInput[i]);
end;
end;
function SummOfEven(arrayToProcess:pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:=0;
for i:=1 to n do
begin
if not odd( arrayToProcess[i]) then res:=res+arrayToProcess[i];
end;
SummOfEven:=res;
end;
function MinimalElement(arrayToProcess: pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:= arrayToProcess[1];
for i:=2 to n do
begin
if(res>arrayToProcess[i]) then res:=arrayToProcess[i];
end;
MinimalElement:=res;
writeln('minimal element: ', res);
end;
begin
clrscr;
N:=0;
while (N15) do
begin
write('Vvedite kol-vo elementov massiva ot 1 do 15: ');
readln(N);
end;
InputArray(myArray, n);
writeln('summa chetnih: ', SummOfEven(myArray, n));
MinimalElement(myArray, n);
readln;
end.
- 13.02.2018 16:15
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.