Вопрос по информатике:
Помогите!СРОЧНО!!!
Надо составить программу для Паскаль ABC
Дано вещественное число.Если оно отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень.
- 26.06.2018 01:01
- Информатика
- remove_red_eye 17671
- thumb_up 88
Ответы и объяснения 1
var
a: real;
begin
writeln('Введите вещественное число');
readln(a); //Вводим вещественное число
if a < 0 then writeln('Модуль числа а: ', abs(a)) {Если введенное число - отрицательное, печатаем его модуль, иначе печатаем квадратный корень из этого числа с округлением до 5 знаков после запятой}
else writeln('Квадратный корень из числа а: ', sqrt(a) : 0 : 5);
end.
- 27.06.2018 17:46
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.