Вопрос по информатике:
№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.
- 07.03.2018 11:01
- Информатика
- remove_red_eye 16830
- thumb_up 73
Ответы и объяснения 1
var a:array[1..10]of integer;
n1,n2,s,i:integer;
begin
n1:=1;
n2:=1;
for i:=1 to 10 do a[i]:=random(10)+1;
for i:=1 to 10 do begin
if a[i] mod 2=0 then n1:=n1*a[i] else n2:=n2*a[i];
s:=s+a[i];
end;
writeln(n1,' ',n2,' ',s/10);
end.
Объеденил все 3 программы: вначале выводит произведение четных, потом нечетных, потом среднее арифм.
- 08.03.2018 11:18
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.