Вопрос по информатике:
Нужно составить программу(ну как всегда Var////Began//// ну и т.д.) Дана дробь a/b. Требуется ее сократить. То есть записать это же число в виде c/d, где c — целое число, d — натуральное число и d минимальное возможное.
- 13.07.2018 18:57
- Информатика
- remove_red_eye 12632
- thumb_up 76
Ответы и объяснения 1
var i,a,b,a1:integer;
begin
readln(a,b);
a1:=a;
for i:=1 to a1 do begin
if (a mod i=0) and (b mod i=0) then begin
a:=a div i;
b:=b div i;
end;
end;
writeln('c=',a,' d=',b);
end.
- 14.07.2018 09:46
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.