Вопрос по информатике:
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел.
- 25.12.2017 14:13
- Информатика
- remove_red_eye 1810
- thumb_up 67
Ответы и объяснения 1
Program Pr1;
uses crt;
var mas:array[1..40] of integer;
i:integer;
v:real;
Begin
clrscr;
v:=0;
randomize;
for i:=1 to 40 do mas[i]:=random(21);
for i:=1 to 40 do v:=v+mas[i];
v:=v/40;
writeln(v);
end.
- 26.12.2017 13:27
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.