Вопрос по информатике:
Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала координат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу
- 09.09.2017 19:38
- Информатика
- remove_red_eye 17326
- thumb_up 83
Ответы и объяснения 1
program prog;
var x1,x2,y1,y2,i,b:integer;
begin;
writeln('Введите 4 точки: x1, y1; x2, y2');
readln(x1,y1,x2,y2);
i:=abs(x1+y1);
b:=abs(x2+y2);
if i=b then writeln('Координаты находятся на одной точке') else begin
if i>b then writeln('Первая координата дальше') else writeln('Вторая координата дальше');
end;
end.
- 09.09.2017 23:13
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.