Вопрос по информатике:
на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел . Печать результата по вводу 0 ( используя цикл while т.е. предусловие ).
- 25.01.2018 16:38
- Информатика
- remove_red_eye 13089
- thumb_up 94
Ответы и объяснения 1
var
a, s: real; //a - вводимое с клавиатуры число, s - сумма чисел
begin
a:= 1; //Присваиваем начальное значение, чтобы цикл выполнился
s:= 0;
while a 0 do
begin
writeln('Введите положительное число');
readln(a);
if a < 0 then
begin
writeln('Введено не положительное число. Повторите ввод заново');
continue; {Если а - не положительное число, вводим число заново}
end;
s:= s + a;
end;
writeln('Сумма: ', s); //Выводим сумму
end.
- 26.01.2018 18:53
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.