Вопрос по информатике:
Задача: написать программу на Паскале, С (С++) или Бейсике.
Входной файл: input.txt.
Выходной файл: output.txt.
Ограничение времени выполнения программы: 1 секунда на тест.
Спецификация входа: в первой строке входного файла записано целое число N (1 N 1000), во второй строке файла записаны целые числа X1, X2, ..., XN, (-109 Xi 109).
Спецификация выхода: запишите в выходной файл числа Xi в порядке неубывания.
Пример входа:
512 10 5 10 7
Пример выхода:
5 7 10 10 12- 15.01.2018 06:13
- Информатика
- remove_red_eye 16233
- thumb_up 94
Ответы и объяснения 1
program exs;
var a : array [1..1000] of integer;
n, i : integer;
procedure qsort(l, r: integer);
var i, j, key, buf : integer;
begin
i := l;
j:= r;
key:=a[(l+r) div 2];
repeat
while a[i] < key do inc(i);
while a[j] > key do dec(j);
if i<=j then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
inc(i);
dec(j);
end;
until (i>j);
if (l < j) then qsort(l, j);
if (i < r) then qsort(i, r);
end;
begin
readln(n);
for i:= 1 to n do begin
read(a[i]);
end;
qsort(1, n);
for i:=1 to n do begin
write(a[i], ' ');
end;
end.
- 16.01.2018 19:58
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.