Вопрос по информатике:
Помогите, пожалуйста, составить программу, в паскале, нахождения суммы цифр четырехзначного числа
- 09.02.2018 15:12
- Информатика
- remove_red_eye 8325
- thumb_up 55
Ответы и объяснения 1
var
a: 1000..9999; //Четырехзначное число
a1, a2, a3, a4: 1..9;
begin
writeln('Введите четырехзначное число');
readln(a);
a1:= a mod 10; //Первая с конца цифра
a2:= (a mod 100) div 10; //Вторая с конца цифра
a3:= (a mod 1000) div 100; //Третья с конца цифра
a4:= a div 1000; //Четвертая с конца цифра
writeln('Сумма цифр данного числа: ', a1 + a2 + a3 + a4); //Сумма цифр
end.
;- 09.02.2018 18:58
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.