Вопрос по информатике:
1)в free pascal составить программу нахождения суммы цифр четырехзначного числа 2) составить программу: если существует треугольник,со сторонами a,b,c , то напечатать "да",а иначе напечатать "нет"
- 20.06.2015 00:40
- Информатика
- remove_red_eye 6901
- thumb_up 41
Ответы и объяснения 1
var sum, k, i: integer;
begin
readln (k);
while k > 0 do
begin
sum := sum + k mod 10; //прибавляем к сумме последнюю цифру в числе k
k := k div 10; //убираем из k эту последнюю цифру
end;
writeln(sum);
end.
var a, b, c: integer;
begin
readln (a);
readln (b);
readln (c);
if (((a + b) > c) and ((a + c) > b) and ((c + b) > a)) then //у треугольника сумма двух сторон больше третьей стороны
writeln('да')
else writeln ('нет');
end.
- 21.06.2015 13:04
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.