Вопрос по информатике:
Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;
- 22.09.2017 02:30
- Информатика
- remove_red_eye 19032
- thumb_up 74
Ответы и объяснения 1
program asd;
uses crt;
var
i:integer;
a: array[1..9] of integer;
naibnum:integer;
naib:integer;
naim:integer;
naimnum:integer;
begin
writeln('Вводите цифры');
for i:=1 to 9 do
begin
readln(a[i]);
if i = 1 then naim:=a[i];
if i = 1 then naib:=a[i];
if a[i] < naim then
begin
naim:=a[i];
naimnum:=i;
end;
if a[i] > naib then
begin
naib:=a[i];
naibnum:=i;
end;
end;
writeln('Наименьшее:',naim, ' номер:', naimnum);
writeln('Наибольшее:',naib, ' номер:', naibnum);
end.
- 23.09.2017 20:31
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.