Вопрос по информатике:
с клавиатуры вводят слово.Составить программу ,которая:
а)определяет количество символов в нём
б)проверяет,не совпадают ли первая и последняя буквы слова
в)выводт на экран первый,второй и последний символы
г)определяет,чётно или нечётно количество символов в нём
- 04.05.2018 00:53
- Информатика
- remove_red_eye 12164
- thumb_up 92
Ответы и объяснения 1
uses crt;
var s: string;
begin
writeln('Напишите слово');
readln(s);
writeln(length(s) ,' символов');
writeln(s[1] ,' первый символ ', s[2] ,' второй символ ', s[length(s)] ,' последний символ');
if (s[length(s)] = s[1]) then
begin
writeln('совпадают');
end
else writeln('не совпадают');
if (length(s) mod 2 = 0) then
begin
writeln('четное кол-во');
end
else writeln('не четное');
end.
- 05.05.2018 00:26
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.