Вопрос по информатике:
С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно; или сумме максимального и минимального из них, если минимальное число неотрицательно.
Ничего, кроме указанного числа, программа выводить не должна.
С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.
Каждое число программа должна выводить в отдельной строке; ничего, кроме чисел, программа выводить не должна.
С3.См. фото.
- 24.09.2018 01:07
- Информатика
- remove_red_eye 3289
- thumb_up 79
Ответы и объяснения 1
По первой задаче, предполагается, что пользователь корректно всё ввёл:
program c1;
uses crt;
var b:array[1..3] of shortint;
min:integer;
max:integer;
i:integer;
begin
for i:=1 to 3 do
begin
readln(b[i]);
if(i=1) then
begin
min:=b[i];
max:=b[i];
end;
if(b[i]
min:=b[i];
end;
if(b[i]>max) then
begin
max:=b[i];
end;
end;
if(min<0) then
begin
writeln(min*max);
end else
begin
writeln(min+max);
end;
end.
------------------------------------------------------------------------------------------------
Задача номер 2
program c2;
uses crt;
var b:array[1..12] of word;
i:integer;
N:byte;
begin
readln(N);
for i:=1 to N do
begin
readln(b[i]);
end;
for i:=N downto 1 do
begin
writeln(b[i]);
end;
for i:=1 to N do
begin
if b[i] mod 8 = 3 then writeln(b[i]);
end;
end.
----------------------------------------------------------------------------------
Задача номер 3
program c3;
uses crt;
var x,y:real;
begin
readln(x);
readln(y);
{check e or not e}
if(x*x + y*y)>4 then
begin
writeln('E'); {snaruzhi okruzhnosti}
end else
begin
if(y>3*x) then {C ili B}
begin
if(y>-3*x) then writeln('B') else writeln('C');
end else {A ili D}
begin
if(y>-3*x) then writeln('A') else writeln('D');
end;
end;
end.
в третьей задаче 1 проверяем точка в окружности или за окружностю, затем проверяем выше она первой прямой или ниже, и также со второй прямой. в зависимости от результатов проверки делаем вывод. Задавайте вопросы
- 25.09.2018 12:27
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.