Вопрос по информатике:
Составьте программу, которая запрашивает три целых числа и , если ни одно из чисел не равно нулю, выводит на экран их среднее арифметическое.
- 18.11.2017 21:29
- Информатика
- remove_red_eye 11307
- thumb_up 69
Ответы и объяснения 1
Program d;
var a,b,c:integer;
Begin
Writeln('введите 3 целых числа через пробел'); Read(a,b,c);
if (a0) and (b0) and (c0) then writeln((a+b+c)/3)
else writeln('одно из чисел равно нулю');
Readln;
end.
Проверил - все работает. Если возникнут вопросы - пиши в личку.
Удачи!
- 19.11.2017 13:10
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.