Вопрос по информатике:
паскаль
1)
Составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем.
2)
Составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и разность прогрессии вводятся пользователем. Вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.
- 01.09.2018 04:55
- Информатика
- remove_red_eye 2098
- thumb_up 81
Ответы и объяснения 1
1)
var a: 1000..9999;
a1, a2, a3, a4: 1..9;//Цифры числа
begin
writeln('Введите четырехзначное число');
readln(a);
a4:= a mod 10; //Последняя цифра
a3:= (a mod 100) div 10;
a2:= (a mod 1000) div 100;
a1:=a div 1000;//Первая слева цифра
writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);
end.
2)
var
n: integer;
d, s: real;
a1: real;
begin
writeln('Введите число n');
readln(n);
writeln('Введите разность прогрессии');
readln(d);
writeln('Введите первый элемент');
readln(a1);
s:= ((2*a1+d*(n-1))/2)*n;
writeln('Номер: ', n-1, ' Значение: ', a1+d*(n-2));
writeln('Номер: ', n, ' Значение: ', a1+d*(n-1));
writeln('Номер: ', n+1, ' Значение: ', a1+d*n);
writeln('Сумма ', n, ' первых элементов равна: ',S);
end.
- 01.09.2018 22:20
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.