Вопрос по информатике:
Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)
- 11.12.2017 21:49
- Информатика
- remove_red_eye 10493
- thumb_up 87
Ответы и объяснения 1
Паскаль.
program jjj;
var a: array [1..10] of integer; i,summa,proizv:integer;
begin
for i:=1 to 10 do begin
Writeln('напишите элемент массива номер ',i); read(a[i]);
end;
For i:=1 to 10 do begin
if a[i] mod 2=0 then summa:=summa+a[i] else
if (a[i]=1) then proizv:=proizv*a[i];
end;
Writeln(summa,' ',proizv); readln;
end.
Жирным - это то, что я добавил)
- 11.12.2017 21:56
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.