Вопрос по информатике:
Нужно сделать в паскаль АВС
Самолет летит из пункта А в пункт Б со средней скоростью V. Составить программу для нахождения времени полёта t1, если есть встречный ветер, скорость которого V1, и времени t2, если ветра нет. Расстояние между пунктами A и Б считать известным и равным S.
- 12.09.2017 01:01
- Информатика
- remove_red_eye 11014
- thumb_up 104
Ответы и объяснения 1
var S, V, V1: real;
t1, t2: real;
b: boolean;
begin
b:=false;
repeat
writeln('Введите расстояние между пунктами А и Б');
readln(S);
if S<0 then
begin
writeln('Отрицательное расстояние. Повторите ввод');
continue;
end;
writeln('Введите среднюю скорость самолета');
readln(V);
if V<0 then
begin
writeln('Отрицательная скорость. Повторите ввод');
continue;
end;
writeln('Введите скорость встречного ветра');
readln(V1);//Если ветра нет нужно ввести 0
if V1<0 then
begin
writeln('Отрицательная скорость. Повторите ввод');
continue;
end;
b:=true;
until b = true;
if V1>0
then
begin
t2:=S/V;
writeln('Время полета: ', t2);
end
else
begin
t1:=(V-V1)/S;
writeln('Время полета: ', t1);
end;
end.
- 13.09.2017 16:44
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.