Вопрос по информатике:
напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal
- 04.06.2018 15:06
- Информатика
- remove_red_eye 6879
- thumb_up 53
Ответы и объяснения 1
Program n1;
Uses CRT;
Var s,i: integer;
begin
ClrScr;
Writeln('Введите последовательность. Для остановки введите 0 ');
Repeat
readln(i);
If (i mod 7=0)or(i mod 10=0) then s:=s+i;
until i=0;
writeln('Сумма =',s);
readln
end.
- 05.06.2018 10:48
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.