Вопрос по информатике:
Задача на циклы,пожалуйста,напишите программу Составьте программу определения наибольшего общего делителя двух натуральных чисел. (3 балла)
- 15.01.2018 23:59
- Информатика
- remove_red_eye 9171
- thumb_up 54
Ответы и объяснения 1
Используем стандартный алгоритм нахождения Нод.
Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite A i B');
Readln(a,b);
while b0 do
begin
c := a mod b;
a := b;
b := c;
end;
writeln('NOD =',a);
readln
end.
- 17.01.2018 13:06
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.