Вопрос по информатике:
Составить программу на языке Паскаля: Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон: равносторонний,равнобедренный или какой либо другой.
- 21.09.2018 04:00
- Информатика
- remove_red_eye 16243
- thumb_up 73
Ответы и объяснения 1
var a,b,c: integer;
begin
readln(a,b,c);
if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;
if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');
if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');
if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');
end.
- 22.09.2018 15:52
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.