Вопрос по информатике:
доброго времени суток.) кто-нибудь может помочь?ибо я совсем не вывожу информатику.
1.Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.
2..Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:
а) 1 3 4 -2
б)0 1 -2 10 11 12 -10 -3
в)1 1 1 1 -1 -1 -1 -1
очень прошу-у-у, уделите время, если Вас не затруднит.
- 05.11.2017 17:24
- Информатика
- remove_red_eye 11538
- thumb_up 55
Ответы и объяснения 1
1)
var a:array [1..100] of integer; объявляем массив
i,n:byte; объявляем вспомогательную переменную i и переменную n для хранения количества элементов
begin
write('Введите n = ');readln(n); вводим n
for i:=1 to n do begin от 1 до n цикл
write('a[',i,']=');
readln(a[i]); вводим элементы в массив
end;
write('Исходный массив: ');
for i:=1 to n do выводим наш массив полностью
write(a[i],' ');
writeln;
write('Результат: '); выводим результат, в данном случае все элементы стоящие на четных местах
for i:=1 to n do
if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент
end.
2)
var a:array [1..100] of integer;
i,n:byte; s:longint; s объявляем для хранения суммы элементов
begin
s:=0; обнуляем s
write('Введите n = ');readln(n); тут тоже самое, что и в первой задаче
for i:=1 to n do begin
write('a[',i,']=');
readln(a[i]);
s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s
end;
write('Исходный массив: ');
for i:=1 to n do вывод массива
write(a[i],' ');
writeln('Сумма всех элементов массива = ',s); вывод суммы
end.
Удачи=)
- 06.11.2017 21:09
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.