Вопрос по информатике:
Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?????
- 04.11.2017 02:11
- Информатика
- remove_red_eye 2689
- thumb_up 62
Ответы и объяснения 1
var s:string;
i,n,max:byte;
begin
n:=0;i:=1;max:=0;
write('Введите s -> ');readln(s);
while i<=length(s) do begin
if (i=1) or (s[i]=' ') then begin
if i 1 then inc(i);
if (i<=length(s))and((s[i]='a') or (s[i]='A')) then
while i<=length(s) do
if s[i]' ' then begin
inc(n);
inc(i);
end else break;
end;
inc(i);
if max
end;
write('Длина самаго длинного слова на букву A = ',max);
end.
- 05.11.2017 06:50
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.