Вопрос по информатике:
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после перестановки цифр. В противном случае, вывести выбранное ПК число
- 01.01.2018 04:41
- Информатика
- remove_red_eye 8572
- thumb_up 89
Ответы и объяснения 1
var x,x1,x2,x3: integer; //x1- 1 число, х2- 2 число, х3 - 3 число
begin
randomize;
x:=random(1000)+10;
if x div 100 >0 then begin x1:=x div 100;
x2:=(x mod 100) div 10;
x3:=(x mod 100) mod 10;
writeln(x,', ',x3,x2,x1);
end
else writeln(x);
end.
- 02.01.2018 20:42
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.