Вопрос по информатике:
Информатика "Программирование разветвляющихся алгоритмов"
1. Написать программу, определяющую по длинам сторон A. B. C, является ли треугольник равнобедренным.
2. Даны радиусы круга и сторона квадрата. У какой фигуры площадь больше? 3. Даны два различных вещественных числа X и Y. Написать программу возведения наименьшего из чисел в квадрат, наибольшего в куб и нахождения среднего арифметического полученных знаний. Метки:
- 11.10.2017 14:12
- Информатика
- remove_red_eye 11195
- thumb_up 73
Ответы и объяснения 1
var a,b,c,r,x,y:integer;
Begin
read(a,b,c);
if (a=b) or (a=c) or (b=c) then
writeln('Ravnobedrennyj');
read(a,r);
if (a*a>pi*r*r) then writeln('Kvadrat bolshe')
else writeln('Krug bolshe');
read(x,y);
if x>y then writeln(y*y,' ',x*x*x,' ',(x+y)/2);
else writeln(x*x,' ',y*y*y,' ',(x+y)/2);
End.
- 12.10.2017 00:34
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.