Вопрос по информатике:
С клавиатуры вводится трехзначное число. Составьте программу выводящую сумму его чисел.
- 23.03.2018 21:58
- Информатика
- remove_red_eye 19170
- thumb_up 64
Ответы и объяснения 1
var
a, s: integer; // целочисленный тип данных
begin
writeln('Введите число:');
readln(a); // вводим число (можно больше трех знаков)
while a 0 do // пока остались цифры в числе выполнять...
begin
s := s + (a mod 10); // Отбираем последнюю цифру числа и прибавляем к сумме
a := a div 10; // Стираем последнюю цифру числа
end;
writeln('Сумма цифр = ', s) // выводим результат
end.
- 24.03.2018 14:26
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.