Вопрос по информатике:
НАЙТИ средний бал за контрольную работу если кол-во учеников выполнявших работу n. Также найти колличество учеников которые получили оченку 4 или 5,а также оченку 2
составить программу в гамбас(не обязательно программу если можно просто решение объяните)
- 07.09.2015 20:45
- Информатика
- remove_red_eye 18611
- thumb_up 64
Ответы и объяснения 1
не наю че за гамбас
пишу на паскале
var a:array[1..100] of integer;
i,n,k5,k4,k2:integer;
s:real;
Begin
read(n);
for i := 1 to n do begin
writeln('Ввведите оценку учиника ',i);
readln(a[i]);
s:=s+a[i];
if a[i]=5 then k5:=k5+1;
if a[i]=4 then k4:=k4+1;
if a[i]=2 then k2:=k2+1;
end;
writeln(s/n,k5,k4,k2);
End.
- 08.09.2015 16:43
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.