Вопрос по информатике:
составить программу в Pascal ABC , которая строит изображение предмета в плоском зеркале (расстояние от предмета до зеркала вводится с клавиатуры)
- 05.01.2018 02:17
- Информатика
- remove_red_eye 4932
- thumb_up 81
Ответы и объяснения 1
Картинка длжна быть в папке с программой и быть в формате BMP
uses
graphabc;
var
n: string;
b: Picture;
s:integer;
begin
writeln('введите расстояние до зеркала');
readln(s);
write('Введите имя файла рисунка: ');
readln(n);
window.Clear;
b := Picture.Create(n);
b.Load(n);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(50+2*s,50);
end.
- 05.01.2018 21:45
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.