Вопрос по информатике:
Написать программу в Pascal даны целые числа а1...аn. Если в данной последовательности ни одно четное число не расположено после нечетного.то получить все отрицательные члены последовательности иначе-положительное.
- 15.12.2017 17:50
- Информатика
- remove_red_eye 15482
- thumb_up 76
Ответы и объяснения 1
var
a: array[1..50] of integer;
i,f, n: integer;
begin
write('n=');
readln(n);
for i := 1 to n do
begin
write('a', i, '=');
readln(a[i]);
end;
f := 0;
writeln;
for i := 1 to n - 1 do
if (a[i] mod 2 0) and (a[i + 1] mod 2 = 0) then f := 1;
if f = 0 then
begin
for i := 1 to n do
if a[i] < 0 then write(a[i]:4);
end
else
for i := 1 to n do
if a[i] > 0 then write(a[i]:4);
end.
- 15.12.2017 23:01
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.