Вопрос по информатике:
Написать программу для Паскаля :найдите наименьший элемент квадратной таблицы и замените его нулем
- 10.09.2018 17:53
- Информатика
- remove_red_eye 15492
- thumb_up 73
Ответы и объяснения 1
var
i, j, min, min_i, min_j: integer;
a: array[1..5, 1..5] of integer;
begin
for i := 1 to 5 do
begin
for j := 1 to 5 do
begin
a[i, j] := random(100) + 1;
write(a[i, j]:4);
end;
writeln;
end;
min := 999;
for i := 1 to 5 do
for j := 1 to 5 do
if min > a[i, j] then
begin
min := a[i, j];
min_i := i;
min_j := j;
end;
a[min_i, min_j] := 0;
writeln('Массив с замененным минимальным элементом');
for i := 1 to 5 do
begin
for j := 1 to 5 do
write(a[i, j]:4);
writeln;
end;
end.
- 11.09.2018 08:08
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.