Вопрос по информатике:
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y=(1-2/5)+(2+4/10)+(3-8/15)+(4+16/20)+...
- 14.01.2016 10:07
- Информатика
- remove_red_eye 6164
- thumb_up 16
Ответы и объяснения 1
program zadacha2;
uses crt;
var i,n,a:integer;
b,y,c,l:real;
begin
clrscr;
readln(n);
a:=1;
b:=2;
c:=5;
for i:=1 to n do
begin
if a mod 2 = 0 then
l:=a+b/c
else
l:=a-b/c;
a:=a+1;
b:=b+2;
c:=c+5;
y:=y+l;
end;
writeln(y:2:2);
readkey;
end.
Первую по подробней расспишите
- 15.01.2016 19:45
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.