Вопрос по информатике:
В старояпонском календаре был принят двенадцатилетний цикл. Годы внутри цикла носили названия животных: крысы, коровы, тигра, зайца, дракона, змеи, лошади, овцы, обезьяны, петуха, собаки и свиньи. Написать программу, которая позволяет ввести номер года и печататет его название по старояпонскому календарю. Справка: 1996 г. - год крысы - начало очередного цикла (остаток от деления равен 4).
- 14.02.2018 07:31
- Информатика
- remove_red_eye 11100
- thumb_up 78
Ответы и объяснения 1
var
n:integer;
begin
readln(n);
case n mod 12 of
4:writeln('год крысы');
5:writeln('год коровы');
6:writeln('год тигра');
7:writeln('год зайца');
8:writeln('год дракона');
9:writeln('год змеи');
10:writeln('год лошади');
11:writeln('год овцы');
0:writeln('год обезьяны');
1:writeln('год петуха');
2:writeln('год собаки');
3:writeln('год свиньи');
end;
end.
- 15.02.2018 01:58
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.