Вопрос по информатике:
С клавиатуры вводят слово и символ.составить программу,которая: а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.
- 14.08.2017 10:52
- Информатика
- remove_red_eye 12348
- thumb_up 106
Ответы и объяснения 1
var s : string; symb : char; i : longint;
begin
readln(s);
readln(symb);
if pos(symb,s)=0 then writeln('В этом слове нет этого символа')
else begin
i:=0;
while pos(symb,s)0 do begin
write(pos(symb,s)+i,' ');
i:=i+1;
Delete(s,pos(symb,s),1);
end;
end;
writeln;
writeln(i);
end.
- 15.08.2017 16:31
- thumb_up 53
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.