Вопрос по информатике:
В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого товара и его индекс.
- 17.09.2015 14:15
- Информатика
- remove_red_eye 15969
- thumb_up 23
Ответы и объяснения 1
Массив данных о стоимости товаров зададим в виде целочисленных констант
program primer_1;
const a: array[1..12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58);
i,min,k: integer;
begin
min:=a[1];
for i:=2 to 12 do if a[i] begin min:=a[i]; Или скорее всего этот вариант program primer_1;
k:=i;
write('минимальная стоимость ', min, ' индекс' ,k)
end.
var a: array[1..12] of integer;
i, min, k: integer;
begin
for i:=1 to 12 do read(a[i]);{Ввод стоимостей товаров}
min:=a[1];
k:=0;
for i:=2 to 12 do
if a[i]
begin
min:=a[i];
k:=i;
end;
write('мин. сто-мость ', min, ' индекс ' ,k)
end.
- 18.09.2015 21:53
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.