Вопрос по информатике:
Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.
помогите пожалуйста составить программу в Паскале!!
- 21.05.2016 08:34
- Информатика
- remove_red_eye 9220
- thumb_up 25
Ответы и объяснения 1
program xxx;
var i, j, k, min : integer;
a:array[1..10, 1..20] of integer;
b:array[1..10] of integer;
begin
for i:=1 to 10 do
for j:=1 to 20 do
readln(a[i,j]);
for i:=1 to 10 do
begin
b[i]:=0;
for j:=1 to 20 do
b[i]:=b[i]+a[i,j];
end;
min:=b[1]; k:=1;
for i:=2 to 10 do
if b[i] writeln('наименьшая сумма элементов =', min); writeln('она находится в строке -', k); readln end.
- 22.05.2016 10:06
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.